SOLVED: installing ies4linux under Maverick

1 minute read

Installing ies4linux on Ubuntu Maverick, using this command:

./ies4linux --no-gui and I had the following message:

"Your wine does not have wineprefixcreate installed."

On Ubuntu Maverick, I fixed this message by editing:

vi lib/ and replace

wineprefixcreate &> /dev/null with

wineboot &> /dev/null and also edit:

vi lib/ and replace:

if which wineprefixcreate &> /dev/null; then ( wineprefixcreate 2>&1 ) | debugPipe with

if which wineboot &> /dev/null; then ( wineboot 2>&1 ) | debugPipe

Re-run ies4linux and it runs to completion, and installs ie6 in your ~/bin directory.

This gave me a functioning ie6 under Maverick/Ubuntu 10.10


Mak 2011-10-10 15:51:19

“Hi,\r\n\r\nthanks! I can report it works for Ubuntu 11.04 as well.\r\n\r\nRegards,\r\nMaurice”

Nergal 2011-10-18 08:19:47

“Thanks!\r\nIt helps me in 11.10.”

Jonny 2011-11-07 04:54:56

Thanks, this works in ubuntu 11.10 oneiric ocelot

André 2011-12-06 02:34:29

“Thanks!\r\nWorks fine in my slackware 13.1\r\nCongratulations.”

Nagaraja T 2011-12-14 06:10:47

“Thanks,\r\n\r\nIts works great with oneiric … Thanks for your valuable post”

Mina Nozar 2012-01-18 01:42:59

“Thank you!\r\n\r\nWorked for me on:\r\nDistributor ID: Ubuntu\r\nDescription: \ Ubuntu 11.10\r\nRelease: 11.10\r\nCodename: oneiric”

Thx. It worked for me on Ubuntu 11.10 with wine 1.3.37. Gr8 Stuff.

Mike Ratcliffe 2012-02-24 00:01:39

“Mostly Works. Using Ubuntu 10.10 64bit\r\nNot sure but I think it tried to install IE8 but I might be wrong.”

Samuel Cavazos 2012-03-31 21:16:47

Thanks! Worked on Fedora 16 as well.

srkos 2012-04-12 22:09:32

“Thank You!\r\n\r\nWork on Fedora 16 :)”

Klas 2012-05-13 03:44:17

Thaks you very much for this help, function good under Kubuntu Oneiric.

Chris 2012-07-13 18:16:46

Thanks! Works on opensuse 12.1 too.

James 2012-07-30 06:41:27

“Works on OpenSuSe too!\r\nthanks a lot!”

Mike 2012-09-14 15:04:35

“Great JoB !\r\n\r\nIt worked for me on Ubuntu 11.10 !”

Viktor 2012-10-11 12:56:14

Thanks, works on Linux Mint 11 Katya! Using ies4linux 2.99.0

Martin 2012-12-06 21:20:49

Thanks! Works on Ubuntu 10.04 LTS!

“Ángel Ramírez Isea” 2013-06-21 18:53:21

“Thank you so much! :D\r\n\r\nWorks for Debian 7 (Wheezy) as well.”

Santosh 2013-08-02 09:06:42

“Thanks Dude….\r\n\r\nIt worked for me in Ubuntu 12.04 , but I followed a bit diff step like\r\n\r\nInstalled wine version 1.6 and from wine I downloaded ie7 & ie8.\r\n\r\nOne more help needed how do I run my Local IP i.e localhost from ubuntu terminal to wine ie8.\r\n\r\n\r\nThanks in Advance ……”

Leave a Comment